FANDOM


To forum zostało zarchiwizowane

Odwiedź nowe forum
Forum: Strona główna Problem z importem stron z Wikipedii
Uwaga: Ten temat nie był edytowany od 2497 dni. Jest on uznawany za zarchiwizowany - dyskusja jest zakończona. Nic tu lepiej nie dopisuj. Chyba, że sprawa naprawdę wymaga odpowiedzi lub masz podobny problem i nie chcesz zakładać nowego wątku.

Po ostatniej aktualizacji Mediawiki do wersji 1.19wmf1 (na Wikipedii) mam problem z importem stron z Wikipedii do PrePedii. Przy próbie wgrania jakiegokolwiek pliku zgranego po tej aktualizacji wywala mi komunikat: Import nie powiódł się: Brak stron do importu. Co ciekawe pliki zgrane przed tą aktualizacją importują się bez problemów...

Nie dotyczy to tylko wikipedii ale także np. wikiźródeł, których oprogramowanie też zostało uaktualnione. Z nich też nie da się teraz nic zaimportować.

Może ktoś wie co tam znowu namodzili i jak teraz można zaimportować te pliki do starszych wersji mediawiki, jak ta 1.16.5, na której obecnie chodzi wikia? Electron PL   09:20, mar 5, 2012 (UTC)

Po porównaniu plików exportu znalazłem, że przedtem była używana wersja export-0.5 a teraz jest export-0.6. Różnią się one tym, że doszły jakieś nowe znaczniki:
<ns>0</ns>
....
<sha1 />

w kodzie wygląda to mniej więcej tak:

<ns>0</ns>
<id>88256</id>
<sha1 />

Jak się ręcznie wywali te znaczniki:

<ns>0</ns>
<sha1 />

to już można taki plik zaimportować bez problemów. Na razie sprawdzałem na małym prostym pliku. Nie wiem czy w większych coś tam nie dochodzi jeszcze innego.

Tak czy owak, dobrze by było to poprawić w imporcie aby np. na te kody nie reagował i był wstecznie kompatybilny z tą nowszą wersją albo w ogóle zmienić plik odpowiedzialny za import na nowszą wersję ... Bo problem jest. Electron PL   10:18, mar 5, 2012 (UTC)

Zgłosiłem to wyżej. Sovq 15:33, mar 5, 2012 (UTC)
Dzięki. Dodam tylko, że z moich "badań" wynika, że te <ns>xx</ns> to są po prostu kody przestrzeni nazw, więc dla strony z przestrzeni głównej to będzie <ns>0</ns>, a dla innych przestrzeni odpowiednio inne cyfry ją identyfikujące. Wystarczy wyrzucić wszystkie pary <ns>xx</ns> i <sha1 /> (bo występują zawsze parami przedzielonymi identyfikatorem wersji numeru edycji - ten numer należy oczywiście zostawić) i plik już będzie strawny dla importu wikii. Oczywiście to na razie jest tylko taka ręczna proteza... Electron PL   08:10, mar 6, 2012 (UTC)
A można wiedzieć w jakiej perspektywie można spodziewać się naprawy problemu, bo obecny stan blokuje skutecznie wszelaką aktywność w ww. projekcie, bo dotychczas 90% treści było tu najpierw importowane a następnie dopracowywane. -- Alan ffm (dyskusja) 11:19, mar 18, 2012 (UTC)
Niestety nie jestem w stanie odpowiedzieć na to pytanie. Z mojej strony mogę jedynie zgłosić problem - rozwiązanie go należy do dobrych dusz ze wsparcia technicznego. Możliwe też, że brak kompatybilności stron eksportowanych z MediaWiki 1.19 do innej wiki ze starszej generacji spowoduje, że łatka pojawi się po stronie samej Wikipedii. Z tego co rozumiem, obecnie każda wiki, czy to na Wikii czy poza nią, która nie zaktualizowała swojego silnika do MW 1.19, będzie miała ten problem. Sovq 19:54, mar 18, 2012 (UTC)
No coż, jak widzę, po niedawnej kwietniowej kolejnej aktualizacji oprogramowania Mediawiki w projektach Wikimedia na wersję 1.20 powyższy problem z importem plików XML do Wikii nadal istnieje, także zakładam, że dopóki nie nastąpi tu aktualizacja oprogramowania w Wikii problem się nie rozwiąże, a to z kolei skutecznie blokuje obecnie wszelaką aktywność w ww. projekcie. -- Alan ffm (dyskusja) 16:41, maj 15, 2012 (UTC)