FANDOM


(co odkryłem)
Linia 33: Linia 33:
   
 
Tak czy owak, dobrze by było to poprawić w imporcie aby np. na te kody nie reagował i był wstecznie kompatybilny z tą nowszą wersją albo w ogóle zmienić plik odpowiedzialny za import na nowszą wersję ... Bo problem jest. [[User:Electron PL|''''' Electron PL''''' '''ツ''']][[User talk:Electron PL|&nbsp;<span style="color: #666666">➧</span><span style="color: #C00000">'''☎'''</span>]] 10:18, mar 5, 2012 (UTC)
 
Tak czy owak, dobrze by było to poprawić w imporcie aby np. na te kody nie reagował i był wstecznie kompatybilny z tą nowszą wersją albo w ogóle zmienić plik odpowiedzialny za import na nowszą wersję ... Bo problem jest. [[User:Electron PL|''''' Electron PL''''' '''ツ''']][[User talk:Electron PL|&nbsp;<span style="color: #666666">➧</span><span style="color: #C00000">'''☎'''</span>]] 10:18, mar 5, 2012 (UTC)
  +
  +
::Zgłosiłem to wyżej. <span style="font-size:125%; font-weight:bold; font-family:Trebuchet MS, Helvetica, sans-serif; text-shadow:0 0 0.05em #646464">— [[User:Sovq|Sovq]]</span> 15:33, mar 5, 2012 (UTC)

Wersja z 15:33, mar 5, 2012

Forum: Strona główna Problem z importem stron z Wikipedii
Uwaga: Ten temat nie był edytowany od 3082 dni. Jest on uznawany za zarchiwizowany - dyskusja jest zakończona. Nic tu lepiej nie dopisuj. Chyba, że sprawa naprawdę wymaga odpowiedzi lub masz podobny problem i nie chcesz zakładać nowego wątku.

Po ostatniej aktualizacji Mediawiki do wersji 1.19wmf1 (na Wikipedii) mam problem z importem stron z Wikipedii do PrePedii. Przy próbie wgrania jakiegokolwiek pliku zgranego po tej aktualizacji wywala mi komunikat: Import nie powiódł się: Brak stron do importu. Co ciekawe pliki zgrane przed tą aktualizacją importują się bez problemów...

Nie dotyczy to tylko wikipedii ale także np. wikiźródeł, których oprogramowanie też zostało uaktualnione. Z nich też nie da się teraz nic zaimportować.

Może ktoś wie co tam znowu namodzili i jak teraz można zaimportować te pliki do starszych wersji mediawiki, jak ta 1.16.5, na której obecnie chodzi wikia? Electron PL   09:20, mar 5, 2012 (UTC)

Po porównaniu plików exportu znalazłem, że przedtem była używana wersja export-0.5 a teraz jest export-0.6. Różnią się one tym, że doszły jakieś nowe znaczniki:
<ns>0</ns>
....
<sha1 />

w kodzie wygląda to mniej więcej tak:

<ns>0</ns>
<id>88256</id>
<sha1 />

Jak się ręcznie wywali te znaczniki:

<ns>0</ns>
<sha1 />

to już można taki plik zaimportować bez problemów. Na razie sprawdzałem na małym prostym pliku. Nie wiem czy w większych coś tam nie dochodzi jeszcze innego.

Tak czy owak, dobrze by było to poprawić w imporcie aby np. na te kody nie reagował i był wstecznie kompatybilny z tą nowszą wersją albo w ogóle zmienić plik odpowiedzialny za import na nowszą wersję ... Bo problem jest. Electron PL   10:18, mar 5, 2012 (UTC)

Zgłosiłem to wyżej. Sovq 15:33, mar 5, 2012 (UTC)
Treści społeczności są dostępne na podstawie licencji CC-BY-SA , o ile nie zaznaczono inaczej.